88 lines
2.1 KiB
Nix
88 lines
2.1 KiB
Nix
{
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
|
|
devshell = {
|
|
url = "github:numtide/devshell";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
pre-commit-hooks.url = "github:cachix/git-hooks.nix";
|
|
flake-parts.url = "github:hercules-ci/flake-parts";
|
|
treefmt-nix.url = "github:numtide/treefmt-nix";
|
|
};
|
|
|
|
outputs =
|
|
inputs:
|
|
inputs.flake-parts.lib.mkFlake { inherit inputs; } {
|
|
imports = [
|
|
inputs.devshell.flakeModule
|
|
inputs.pre-commit-hooks.flakeModule
|
|
inputs.treefmt-nix.flakeModule
|
|
];
|
|
|
|
systems = [
|
|
"x86_64-linux"
|
|
"aarch64-linux"
|
|
];
|
|
|
|
perSystem =
|
|
{
|
|
config,
|
|
pkgs,
|
|
system,
|
|
...
|
|
}:
|
|
{
|
|
_module.args.pkgs = import inputs.nixpkgs {
|
|
inherit system;
|
|
config.allowUnfree = true;
|
|
};
|
|
|
|
pre-commit.settings.hooks = {
|
|
treefmt.enable = true;
|
|
};
|
|
devshells.default = {
|
|
imports = [ "${inputs.devshell}/extra/language/c.nix" ];
|
|
language.c = {
|
|
includes = [
|
|
pkgs.libelf
|
|
];
|
|
libraries = [
|
|
pkgs.libelf
|
|
];
|
|
};
|
|
packages = with pkgs; [
|
|
hello
|
|
config.treefmt.build.wrapper
|
|
(python3.withPackages (p: with p; [ tqdm ]))
|
|
];
|
|
commands = [
|
|
{
|
|
package = pkgs.nix;
|
|
help = "nichts";
|
|
}
|
|
];
|
|
env = [
|
|
{
|
|
name = "TEST";
|
|
value = "TSET";
|
|
}
|
|
];
|
|
devshell.startup.pre-commit.text = config.pre-commit.installationScript;
|
|
};
|
|
|
|
treefmt = {
|
|
projectRootFile = "flake.nix";
|
|
programs = {
|
|
clang-format.enable = true;
|
|
cmake-format.enable = true;
|
|
nixfmt.enable = true;
|
|
deadnix.enable = true;
|
|
statix.enable = true;
|
|
shellcheck.enable = true;
|
|
};
|
|
};
|
|
|
|
};
|
|
};
|
|
}
|